Praeambel

Hinweis: Dieses Dokument wurde mit Documenter erstellt und steht daher mit gleichem Inhalt als

  • WebSeite
  • PDF-Datei
  • Windows-Hilfe und
  • ePub

zur Verfügung!

Documenter ist eine Entwicklung von diub zur Erstellung von Dokumentationen aus einer Quellemit unterschiedlichen Zielformaten.

Empfohlene ePub-Reader

ePub-Reader gibt es massenhaft. Nur leider sind die meisten davon schlicht unbrauchbar; falsche Schriften, kaputte Formatierungen usw. sind die Tagesordnung. Am schlimmsten ist jedoch die Unfähigkeit zur Skalierung, für Normalanwender die Änderung der 'Schriftgröße'.

Nachstehend die von mir bevorzugten Reader mit korrekter Darstellung.

  • Browser
    Firefox → Addon EPUBReader (https://addons.mozilla.org/de/firefox/addon/epubreader)
  • Android
    GitdenReader (im PlayStore), schlicht und einfach und es funktioniert alles
  • Windows
    Digital Editions (Adobe), leider - wie alle anderen auch - keine Skalierung der Bilder

Anmerkung: Documenter hält sich nicht 100% an den so genannten ePub-Standard. Der ist aber ohnehin nichts wert. Ein zum Test erstelltes korrektes ePub-Doukument versursachte bei den Readern noch viel mehr Probleme.


1 Nutzungsbedingungen

Haftung

diub bemüht sich im Rahmen des Zumutbaren, richtige und vollständige Informationen zur Verfügung zu stellen. In diesem Sinne ist diub bemüht, nach bekannt werden von Fehlern diese zu beseitigen. Forderungen irgendwelcher Art an diub können daraus nicht abgeleitet werden.

diub behält sich das Recht vor, ohne vorherige oder nachherige Ankündigung Änderungen oder Ergänzungen an den bereitgestellten Informationen oder Programmen vorzunehmen.

diub haftet nicht für direkte oder indirekte Schäden, die aufgrund von oder sonst wie in Verbindung mit Informationen oder Programmen oder durch die Nutzung dieser Informationen oder Programme entstehen.

Alle Informationen oder Programme sind gemäß Ihrer Bestimmung zu gebrauchen. Unsachgemäßer Gebrauch schließt automatisch alle Forderungen gegenüber diub aus. Gleiches gilt für Folgen die durch Mängel, die durch eine Abänderung der Software, durch Beschädigung der Datenträger, durch Missbrauch oder zweckwidrige Nutzung entstehen. Ebenso ausgeschlossen sind Forderungen aus Schäden die durch eine Datensicherung (Backup) oder vergleichbare Maßnahmen vermeidbar sind.

Lizenz

Eine Lizenz besteht aus der Überlassung eines Lizenz-Codes.

Jedem Lizenz-Code ist eine bestimmte Anzahl von Aktivierungen zugeordnet. Die Aktivierung erfolgt Online. Die Software enthält Mechanismen zur Sicherstellung, das die vorgesehene Anzahl an Aktivierungen nicht überschritten wird (Kopierschutz).

Die Lizenz kann dauerhaft oder zeitlich befristet sein.

Rechte

Sie sind berechtigt, das Programm je erworbener einzelner Lizenz auf genau einem Rechner zu installieren und zu betreiben. Bei Installation auf einem Rechner mit Zugriffsmöglichkeiten über Netzwerk (z.B. Server) ist je auf das Programm zugriffsberechtigtem Rechner oder je Rechner auf den zugegriffen wird eine Lizenz zu erwerben.

Kopien zum Zecke der Sicherung und des Erhaltes für die Zukunft sind gestattet.

Sie sind nicht berechtigt, Kopien gegen Entgelt oder sonstige Gegenleistungen oder auch ohne Gegenleistung weiter zu vertreiben oder zu verbreiten.

Beschränkungen

Es ist Ihnen untersagt, die Software zu dekompilieren, sie einer Rückentwicklung zu unterziehen, sie zu zerlegen oder die Software in anderer Form zu entschlüsseln.

Es ist Ihnen untersagt, die Software zu verkaufen, zu mieten, zu vermieten oder eine Unterlizenz dafür zu vergeben.

Sie dürfen die Software nicht abändern oder Derivate davon anfertigen.

Updates

Updates werden soweit möglich kostenfrei zur Verfügung gestellt.

Updates ersetzen die ursprüngliche Version. Updates sind keine neuen Lizenzen und unterliegen den gleichen Beschränkungen wie die erste von Ihnen erworbene Version.


2 Einleitung

Idee

Warum ein Programm wie BoxMapping? Das Internet bietet doch viele Möglichkeiten für dieselbe Aufgabe.

Das ist schlicht falsch. Das Internet bietet gar nichts. Online-Dienstleister bieten sich an. Und jeder verfolgt dabei eigene Ziele. Und haben Sie die AGB dieses Dientleisters gelesen? Und verstanden? Geben Sie vielleicht die Rechte an Ihren Grafiken auf?

BoxMapping bietet Vorteile:

  • Einfache und günstige Lizenz
  • Nichts verlässt Ihren Rechner
  • beliebig viele Projekte in einem offenen Dateiformat (*.XML)

Daneben hat BoxMapping weitere angenehme Eigenschaften:

  • Unterstützung der Zwischenablage
  • Hohe Auflösung
  • Hohe Qualität
  • *.PNG-Format mit Transparenz


3 Funktionen


3.1 Grafiken importieren

Es gibt zwei einfache Möglichkeiten die benötigten Grafiken zu importieren.

  • Über das Menü → Datei → Import
  • Direktes Einfügen über die Zwischenablage
    Selektieren Sie den gewünschten Bereich - angezeigt durch den starken Rahmen - und fügen Sie die Grafik ein.

Tipp

Das Einfügen von Grafiken funktioniert auch mit vielen (Vektor-) Zeichenprogrammen, wie zum Beispiel OpenOffice Draw.


3.2 Winkel und Co

Geändert werden können

  • Breite der Schmalseite
  • Breite der Vorderseite
  • Abstand (Einzug) der Ecken
  • Rotation

Alle Manipulationen lassen sich auch einfach über die Schieberegler durchführen.


3.3 Speichern

Um die Ergebnisse reproduzierbar zu halten, speichern Sie einfach das gesamte Projekt in eine Datei. Gespeichert werden

  • die Einstellungen der Schieberegler
  • die bereits eingefügten Grafiken

BoxMapping verwendet die Dateiendung *.BOX. Es wird im XML-Format gespeichert. So lassen sich im Notfall auch Daten mit einem einfachen ASCII-Editor (zum Beispiel Notepad.exe) auslesen.


3.4 Export

Der Export erfolgt als *.PNG-Datei mit folgenden Eigenschaften:

  • Transparenz für den Hintergrund
  • hohe Auflösung, ca. 1600 x 2500 Pixel, je nach Rotation