1 Nutzungsbedingungen

Haftung

diub bemüht sich im Rahmen des Zumutbaren, richtige und vollständige Informationen zur Verfügung zu stellen. In diesem Sinne ist diub bemüht, nach bekannt werden von Fehlern diese zu beseitigen. Forderungen irgendwelcher Art an diub können daraus nicht abgeleitet werden.

diub behält sich das Recht vor, ohne vorherige oder nachherige Ankündigung Änderungen oder Ergänzungen an den bereitgestellten Informationen oder Programmen vorzunehmen.

diub haftet nicht für direkte oder indirekte Schäden, die aufgrund von oder sonst wie in Verbindung mit Informationen oder Programmen oder durch die Nutzung dieser Informationen oder Programme entstehen.

Alle Informationen oder Programme sind gemäß Ihrer Bestimmung zu gebrauchen. Unsachgemäßer Gebrauch schließt automatisch alle Forderungen gegenüber diub aus. Gleiches gilt für Folgen die durch Mängel, die durch eine Abänderung der Software, durch Beschädigung der Datenträger, durch Missbrauch oder zweckwidrige Nutzung entstehen. Ebenso ausgeschlossen sind Forderungen aus Schäden die durch eine Datensicherung (Backup) oder vergleichbare Maßnahmen vermeidbar sind.

Präambel

Eine Lizenz sowie die daraus abgeleiteten Rechte, Beschränkungen usw. beziehen sich immer auf ein von diub entwickeltes Programm. Open-Source-Anwendungen und Anwendungen anderer Anbieter unterliegen den jeweiligen Bestimmungen.

Lizenz

Eine Lizenz besteht aus der Überlassung eines Lizenz-Codes. Jedem Lizenz-Code ist eine bestimmte Anzahl von Aktivierungen zugeordnet. Die Aktivierung erfolgt Online. Die Software enthält Mechanismen zur Sicherstellung, das die vorgesehene Anzahl an Aktivierungen nicht überschritten wird (Kopierschutz).

Rechte

Sie sind berechtigt, das Programm je erworbender einzelner Lizenz auf genau einem Rechner zu installieren und zu betreiben. Bei Installation auf einem Rechner mit Zugriffsmöglichkeiten über Netzwerk (z.B. Server) ist je auf das Programm zugriffsberechtigtem Rechner oder je Rechner auf den zugegriffen wird eine Lizenz zu erwerben.

Kopien zum Zecke der Sicherung und des Erhaltes für die Zukunft sind gestattet.

Sie sind nicht berechtigt, Kopien gegen Entgelt oder sonstige Gegenleistungen oder auch ohne Gegenleistung weiter zu vertreiben oder zu verbreiten.

Beschränkungen

Es ist Ihnen untersagt, die Software zu dekompilieren, sie einer Rückentwicklung zu unterziehen, sie zu zerlegen oder die Software in anderer Form zu entschlüsseln.

Es ist Ihnen untersagt, die Software zu verkaufen, zu mieten, zu vermieten oder eine Unterlizenz dafür zu vergeben.

Sie dürfen die Software nicht abändern oder Derivate davon anfertigen.

Updates

Updates werden soweit möglich kostenfrei zur Verfügung gestellt.

Updates ersetzen die ursprüngliche Version. Updates sind keine neuen Lizenzen und unterliegen den gleichen Beschränkungen wie die erste von Ihnen erworbene Version.


2 Einleitung

Hinweis: Dieses Dokument (WebSeite, PDF, Windows-Hilfe) wurde mit Documenter erstellt.

Bericht & Liste

Bericht & Liste besteht aus zwei Teilen

  • einer Bibliothek (DLL) zur Einbindung durch .NET - Sprachen, und
  • einem einfachen Editor zur Definition des Layouts.

Bericht & Liste ist besonders geeignet

  • zur leichten Verwendung mit eigenen .Net-Projekten und
  • zur Ergänzung und / oder Anpassung von Berichten, die in Programmen von mir genutzt werden, zum Beispiel TaxiLogbuch.

Bericht & Liste folgt einigen einfachen Prinzipien.

Vermeidung von doppelten Informationen

Die Formatierungen für Absätze und Schriften werden getrennt von den Layout-Elementen gespeichert. Jede benötigte Variante wird genau einmal definiert. Dies wirkt sehr effektiv dem Wildwuchs entgegen.

Schachtelprinzip

Alles was sich in einer Schachtel befindet

  • wird mit der Schachtel verschoben und
  • behält seine Position innerhalb der Schachtel bei.

Das bedeutet, bei Anordung eines neuen Layout-Elementes B unter einem Layout-Element A übernimmt B die Position von A als Nullpunkt. B liegt damit sozusagen in A.

Abgrenzung - was Bericht & Liste nicht ist oder kann

Bericht & Liste ist kein Report-Tool, Bericht & Liste bereitet Daten nicht selbständig auf. Alle Daten die ausgegeben werden sollen, müssen vom aufrufenden Programm fertig generiert werden

Bericht & Liste ist primär für Entwickler gedacht, die die Datenaufbereitung sehr einfach in Ihrem jeweiligen Programm implementieren können.

Die Bibliothek (DLL) zur Ausgabe darf vom Entwickler kostenfrei an seine Kunden weitergegeben werden. Der Editor kann vergünstigt bezogen und weiterveräußert werden, auch als Teil einer eigenen Software.


3 Daten an einen Bericht übergeben

Die Datenübergabe an große Report-Tools erweist sich oft als sehr kompliziert. Bei Bericht & Liste ist sie dagegen sehr einfach.

Daten werden grunsätzlich als beliebige Klassen-Instanzen an Bericht & Liste übergeben.

Wie einfach das geht, zeigen ein paar Beispiele weiter unten.

Allgemein gilt das Folgende:

  • PUBLIC
    nur als public deklarierte Klassen oder Felder können von Bericht & Liste weiterverarbeitet werden.
  • Statische Daten
    sind Daten, die sich über den Bericht oder die Liste nicht ändern, zum Beispiel Namen, Adressen, Titel usw. .
  • Dynamische Daten / Berichtsdaten
    sind die Daten, die als Elemente in einer Tabelle aufgelistet werden sollen.


3.1 Statische Daten


3.2 Dynamische Daten


4 Meta


5 FontSpec


6 Format


7 Layout


7.1 Elemente


7.1.1 Block

Das Block-Element dient als Schachtel.

  • Es hat keinen eigenen Inhalt.
  • Es setzt den Nullpunkt für alle enthaltenen Elemente auf seine Position.
  • Ein Block-Element darf auch andere Block-Elemente enthalten.

Ein Block wird zum Beispiel genutzt zur fixen Positionierung von

  • Absender
  • Anschrift
  • Angabe von Datum oder Seitenzahl
  • Impressum


7.1.2 Text

Das Text-Element dient zur Ausgabe alle Zeichen, Texte usw.. Das Text-Element kann

  • fließend oder
  • beschneidend sein.

Fließender Text

Überschüssiger Text wird entsprechend der Breite des Elements umgebrochen und nach unten fortgeführt.

Diese Variante findet vor allem im Element Fließbereich Einsatz.

Beschnittener Text

Der Text wird entsprechend Breite und Höhe abgeschnitten.

  • Es findet kein Zeilenunbruch statt: ragt eine Zeile über die Breite hinaus, wird der Rest der Zeile verworfen.
  • Enthält der Text mehr Zeilen, als ind die Höhe hineinpassen, werden die überhängigen Zeilen verworfen.


7.1.3 Bild

Das Bild-Element dient der Ausgabe eines Bildes.

  • Die Ausgabe erfolgt unabhängig vom Orginal immer skaliert entsprechend Breite und Höhe des Elements.
  • Die Skalierung erfolgt erst zum Zeitpunkt der Ausgabe.


7.1.4 Linie

Das Linien-Element zieht eine einzelne Linie von seiner Position nach der Position+Größe.

  • Für eine horizontale Linie setzen Sie die Höhe auf Null (0),
  • für eine senkrechte Linie entsprechend die Breite.